0 Flares 0 Flares ×

Lets-Box | WordPress Plugin

This plugin will help you to easily integrate Box into your WordPress website or blog. Lets-Box allows you to view, download, delete, rename files & folders directly from a WordPress page. You can use Lets-Box as a filebrowser, gallery, audio- or video-player!

Otohits.net, fast and efficient autosurf

NOTE: Lets-Box uses the Offical Box API.

Google Drive: We have also a Google Drive variant of this plugin with even more powerful features!. If you only want to use the Gallery function you really should consider Use-your-Drive as it is much faster.

Use your Drive - Google Drive plugin for WordPress


File browser

  • View Box folders & files directly on your site
  • Upload form so users can upload (multiple) files to Box
  • Add, delete and rename files & folders
  • Search your Google for files & folders and even in contents
  • If needed you can restrict users so they are only able to use their ‘own’ Box folder


  • Great looking grid with lightbox
  • Folder thumbnails shows whats inside the folder
  • Customize image row height
  • Shuffle images
  • Add, delete and rename images

Audio & Video

  • Streams audio files directly from your Box with a HTML 5 audioplayer with flash-fallback
    • .m4a (AAC/H.264)
    • .oga (Vorbis/Theora)
    • .mp3
  • Streams video files directly from your Box with a HTML 5 audioplayer with flash-fallback. (Do always supply a mp4 or m4v file for cross-browser support)
    • .webmv (Vorbis/VP8)
    • .ogv (Vorbis/Theora)
    • .mp4 (Limited support)
    • .m4v (AAC/H.264)
  • Multiple awesome skins


  • Sort files by name, size or modified date
  • Restrict viewing by file extension and file or folder name
  • Restrict uploading files by file extension
  • Restrict which user can see, download, rename or delete your files or upload new ones. You can set the required roles by yourself
  • Secure OAuth 2 authentication
  • Powerful but intuitive shortcode generator
  • Multi Sites supported
  • Multi language supported
  • Auto-updater
  • And finally… All elements are responsive!

Do you miss a feature? Let us know!


  • At least PHP 5.3 with cURL extension and ‘allow_url_fopen’ enabled

Not compatible with


Use your Drive - Google Drive plugin for WordPress


= 1.0 (8 July 14) =

  • Initial release version

0 Flares Twitter 0 Facebook 0 Google+ 0 Pin It Share 0 LinkedIn 0 Email -- 0 Flares ×

Leave a Reply

Your email address will not be published. Required fields are marked *